Migrating from older versions of MPF

Upgrading MPF to the latest version

This is covered in the relevant install sections:

If you are upgrading from 0.21 (or earlier) you need to install Python 3 (as explained in the installation section for your platform).

Migrate your config

A migrator exists for config version 3 (0.21 and earlier) to 4 (0.30 to 0.33). There is no automated migrator from version 4 to 5 (0.33 to 0.50). Instead, there is a migration guide to make the necessary changes manually. If you encounter any problems during migration feel free to ask in the forum.